您好,欢迎来到商国互联!

收藏本站
丨
丨
丨

商国互联

点击查看优质供应商

当前位置:商国互联首页> 供应信息 > 商务服务、广告 > 教育、培训 > 资格考试培训

石家庄银行培训,Hadoop 集群常见错误 

石家庄银行培训,Hadoop 集群常见错误

  • 品 牌:
  • 价 格:面议 /
  • 供 应 地:河北省石家庄市
  • 包装说明:
  • 产品规格:
  • 运输说明:
  • 交货说明:
  • 发布日期:2016/3/17 10:51:11
  • 联系人QQ:419510645 点击这里给我发消息

详细说明

详细说明Explain

石家庄银行培训,Hadoop 集群常见错误

(一)启动hadoop集群时易出现的错误:


错误1:java.net.NoRouteToHostException: No route to host.


原因:master服务器上的防火墙没有关闭。

解决:在master上关闭防火墙: chkconfig iptables off.


错误2:org.apache.hadoop.ipc.RPC: Server at JMN/10.22.1.203:9000 not available yet.    /* JMN/10.22.1.203 是  hadoop集群当中master的主机名/ip */


原因:/etc/hosts中的文件被自动篡改。

解决:将/etc/hosts 文件按配置文件要求改回来。


错误3:Too many fetch-failures.


原因:结点间的连通不够全面。

解决:

1) 检查 /etc/hosts要求本机ip对应服务器名,并且包含所有的服务器ip和服务器名。


2) 检查 .ssh/authorized_keys要求包含所有服务器(包括其自身)的public key。


(二)  在hadoop集群的master中用命令运行例子易出现的故障:


错误1:java.lang.OutOfMemoryError: Java heap space.


原因:JVM内存不够。

解决:修改mapred-site.xml中mapred.child.java.opts属性的值,其默认值是-Xmx200m 可根据需要适当增大 该值。


错误2:could only be replicated to 0 nodes, instead of 1


解决:在NameNode上执行命令:hadoop namenode –format重新格式化HDFS,在格式化之前,需要将你  NameNode上所配置的dfs.name.dir这一namenode用来存放NameNode 持久存储名字空间及事务日志的本地文件系统路径删除,同时将各DataNode上的dfs.data.dir的路径DataNode存放块数据的本地文件系统路径的目录也删除。


错误3:namenode in safe mode.


原因:hadoop进入安全模式。

解决:在shell中执行命令hadoop dfsadmin -safemode leave 使hadoop离开安全模式。


(三)在WINOOWs下Eclipse中运行例子易出现的错误:


错误1:org.apache.hadoop.security.AccessControlException: Permission denied: user=administrator, access=EXECUTE, inode="job_201111031322_0003":heipark:supergroup:rwx-.


原因:本地用户administrator(本机WINOOWs用户)想要远程操作hadoop系统,没有权限引起的。


解决:

i、如果是测试环境,可以取消hadoop hdfs的用户权限检查。打开conf/hdfs-site.xml,找到dfs.permissions属性修改为false(默认为true)OK了。

ii、修改hadoop LOCAIION参数,在advanced parameter选项卡中,找到hadoop.job.ugi项,将此项改为启动hadoop的用户名即可。


错误2:IOException: Cannot run program "chmod": CreateProcess error=2.


原因: 没有安装cygwin或 没有配置环境变量。

解决:安装并配置环境变量 bin到 path下 重启 eclipse 问题即可。


错误3: WARN mapred.LocalJobRunner: job_local_0001

java.lang.OutOfMemoryError: Java heap space

at org.apache.hadoop.mapred.MapTask$MapOutputBuffer.<init>(MapTask.java:781)

at org.apache.hadoop.mapred.MapTask.runOldMapper(MapTask.java:350)

………..


原因:客户端程序运行时java虚拟机内存分配不够

解决:修改run configuration,选择Arguments选项卡,在VM arguments栏中加入-Xmx1024m,保存即可解决问题。

石家庄银行培训,数据分析培训。数据挖掘培训

官网:http://www.hbcpda.com

QQ:1563591818


 

卖家名片Cards

卖家名片

石家庄普翔人力资源有限公司

联系人:李文雅(业务)

手机:13393211060

邮箱:419510645@qq.com

地址:河北省石家庄市河北省石家庄市桥西区红旗大街88号翰林观天下22号楼7楼

电话: 传真:

旺铺

在线询盘/留言Online Inquiry

  • *您的姓名:

  • *联系手机:

  • 固话电话:

  • E-mail:

  • 所在单位:

  • 需求数量:

  • *咨询内容:

免责声明:交易有风险,请谨慎交易,以免因此造成自身的损失,本站所展示的信息均由企业自行提供,内容的真实性、准确性和合法性由发布企业负责。本站对此不承担任何保证责任。
商国互联供应商 品质首选

石家庄普翔人力资源有限公司

  • 联系人:李文雅(业务)
  • 电话:
  • 会员级别:免费会员
  • 认证类型:企业认证
  • 企业证件:已通过企业认证 [已认证]
  • 认证公司:
  • 主营产品:cpda资格认证 cpda培训 cpda考试
  • 公司所在地:河北省石家庄市